Difference between revisions of "Ubuntu"

From ConTeXt wiki
(backported repo for 7.04)
Line 7: Line 7:
 
== Feisty (7.04) ==
 
== Feisty (7.04) ==
  
As of today (January 2007), feisty is still alpha test.  But when it is released, you should be able to follow the [[Debian installation]]
+
Unfortunately, you cannot use the repository given in [[Debian installation]] because the Debian packages were compiled with a (very very slightly) newer libc6 than the one that ships with Ubuntu 7.04.  Here instead are very untested packages backported to Ubuntu 7.04:
instructions.
+
 
 +
  <nowiki>deb    http://web.mit.edu/sanjoy/texlive-backports/ feisty/
 +
  deb-src http://web.mit.edu/sanjoy/texlive-backports/ feisty/</nowiki>
 +
 
 +
I use these packages on my laptop with no problems so far (half a day of testing), but let me (Sanjoy) know if you find anything broken.  (They should finish uploading in an hour or two.)
  
 
== Edgy (6.10) ==
 
== Edgy (6.10) ==

Revision as of 02:33, 20 May 2007

Each successive version of Ubuntu becomes easier to update, which is why the following sections, arranged in reverse chronological order, get successively longer.

Late-breaking bad news for Ubuntu users (March 2007)

The latest Debian packages starting with ConTeXt 2007.03.19 require the texlive 2007 packages. Unfortunately, those packages are built against libpoppler0c2, which hasn't shipped on Ubuntu in an age. And it's not easy to recompile it against libpoppler1, which is part of Ubuntu. So: You won't be able to upgrade until a workaround is figured out, which makes the rest of this page irrelevant until then.

Feisty (7.04)

Unfortunately, you cannot use the repository given in Debian installation because the Debian packages were compiled with a (very very slightly) newer libc6 than the one that ships with Ubuntu 7.04. Here instead are very untested packages backported to Ubuntu 7.04:

  deb     http://web.mit.edu/sanjoy/texlive-backports/ feisty/
  deb-src http://web.mit.edu/sanjoy/texlive-backports/ feisty/

I use these packages on my laptop with no problems so far (half a day of testing), but let me (Sanjoy) know if you find anything broken. (They should finish uploading in an hour or two.)

Edgy (6.10)

You can follow the Debian installation instructions. However, the packages depend on having tex-common later than v0.35, and the tex-common in edgy is v0.25. So go to http://packages.ubuntu.com/tex-common and get the feisty (7.04) package, which will be v0.42 or later, and install it by hand using

 dpkg -i tex-common_0.42_all.deb 

Now go to Debian installation.


I was able to install the libpoppler0c2 library, a recent texlive, and context 2007.04.17 on my laptop running Edgy simply by using the debian unstable repository. It seems to work fine. Backup your disk before mixing in packages from unstable.

--Lee-phillips 05:57, 15 May 2007 (CEST)

Dapper (6.06)

Ubuntu 6.06 contains teTeX 3.0 (including ConTeXt 2005.01.31), so you can just install tetex-extra and use ConTeXt. However, once you got your feet wet, you will probably want to install a more recent pdfTeX than the 1.21a installed with Ubuntu (since ConTeXt can give you more features with newer pdfTeX's), so again, please follow the instructions for TeTeX_3.0 installation.

The instructions for Fedora Core 5 are valid for Ubuntu 6.06, with a few caveats:

  • Ubuntu's default installation lacks a few tools that you'll need to build a new version of pdfTeX and to run new versions of ConTeXt. So before upgrading, do:
 sudo apt-get install build-essential bison flex ruby 
  • The configuration files that users should edit are under /etc/texmf/texmf.d. Do not edit the .cnf files in /usr/share/texmf/web2c directly; instead, edit the configlet files in the .d directory and run update-texmf or update-updmap.

After doing all of the above, the new versions seem to be working:

% texexec --version

 TeXExec 5.4.3 - ConTeXt / PRAGMA ADE 1997-2005

               texexec : TeXExec 5.4.3 - ConTeXt / PRAGMA ADE 1997-2005
               texutil : TeXUtil 9.0.1 - ConTeXt / PRAGMA ADE 1992-2006
                   tex : pdfTeX, 3.141592-1.40.0-beta-20060213 (Web2C 7.5.5)
               context : ver: 2006.04.23 23:55
               cont-en : ver: 2006.04.23 23:55  fmt: 2006.4.24  mes: english

Breezy (5.10)

Breezy's support ends in April 2007, so you are advised to upgrade (one Ubuntu release at a time) to a more recent release in order to run a secure system; Dapper (6.06) will be supported until 2009, so that could be a good choice. The following instructions are for those who cannot (or do not wish to) upgrade.

Ubuntu 5.10 does not include a TeX installation by default. The distribution that you get when you install TeX is teTeX-2.0.2, which is too old and will not work with recent ConTeXt versions. So you should not install it, but follow the instructions for TeTeX_3.0_installation. However, you first must install supplementary packages not included in Ubuntu by default (and I hope I'm not forgetting anything; a number of dependencies will automatically be installed as well):

 # sudo apt-get install build-essential bison flex libncurses5-dev ruby

Install these packages before trying to compile teTeX 3.0 or running newer ConTeXt release (which use ruby rather than perl), or you will get errors during the compilation or have problems running the results.